New patient episodes not showing
Incident Report for Dialogue
Resolved
This incident has been resolved.
Posted Dec 08, 2017 - 12:45 EST
Investigating
New patient episodes may not be appearing in the care platform
Posted Dec 08, 2017 - 12:06 EST