Android push notifications are not working
Incident Report for Dialogue
Postmortem

Issue Summary

  • Login on care platform
  • Send message to android user (with a backgrounded app)
  • User doesn't receive push notification

Root Cause

  • Application configuration was using a legacy GCM sender ID used for push notification on android;
  • Our legacy sender ID has been marked deprecated yesterday morning and Google switched to use firebase only sender ID;

Resolution and recovery

  • OTA update for the 2.5.0 apps with the changed sender ID to a FCM id (853821706454);

Corrective and Preventative Measures

  • We have had issues in the past with push notifications, and they all end up being some form of configuration issue;
  • Firebase console does not show error details, always use the API to troubleshoot: at API level, the root cause is clearly mentioned;
  • Last but not least, anytime there is an issue with push notifications, triple check the configuration of the App;
Posted Dec 05, 2017 - 19:52 EST

Resolved
This incident has been resolved.
Posted Dec 05, 2017 - 19:25 EST
Update
After troubleshooting, we strongly believe the issue is on Firebase/Google cloud messaging.
Firebase/Google status page reports a service disruption on Firebase Console that seems to be related to our issue.
We've reported the issue to the Firebase/Google Cloud Messaging team.
Posted Dec 05, 2017 - 15:04 EST
Investigating
We are currently investigating this issue.
Posted Dec 05, 2017 - 11:58 EST