Issues updating episodes: Health Type, Priority, Resolve
Incident Report for Dialogue
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 10, 2018 - 14:09 EST
Investigating
We are currently investigating the issue
Posted 6 months ago. Dec 10, 2018 - 11:28 EST
This incident affected: Care Platform.