Cannot make phone calls from the Care Platform
Incident Report for Dialogue
Resolved
The Montreal office Internet issues should have been resolved. Reload you CP and let us know if you have any further issues.
Posted 27 days ago. Jun 25, 2019 - 10:50 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 27 days ago. Jun 25, 2019 - 09:49 EDT
Investigating
We are investigating
Posted 27 days ago. Jun 25, 2019 - 08:44 EDT
This incident affected: Care Platform.