Partial Care Platform Outage: Episode Assignments
Incident Report for Dialogue
Resolved
The incident has been resolved.
Posted 10 months ago. Nov 05, 2018 - 17:26 EST
Investigating
We are investigating an issue where Care Team Members are unable to see assigned episodes.
Posted 10 months ago. Nov 05, 2018 - 17:12 EST
This incident affected: Care Platform.