Call in CP Outage
Incident Report for Dialogue
Resolved
This incident has been resolved.
Posted 12 days ago. Apr 08, 2019 - 10:21 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 12 days ago. Apr 08, 2019 - 09:42 EDT
This incident affected: Care Platform.